Building urho3d from src

I’ve successufully builded urho3d with Cmake

cannot open file urho3d_d.lib when in debug
cannot open file urho3d.lib when in release

errors pops up so what to do ?

Did you try running some of the compilation output located in the bin folder?

Also, welcome to the forums! :confetti_ball:

thank you, in my bin folder, there are bat files what for ? my x64/release is empty since build fails

Ah, your successful build process fails. Check :slight_smile:

Then, have you tried the scripts in the script folder before running make?

And I assume you’ve found your way to the documentation?

there is nothing special in the documentation :confused:
the script folder before or after running make is filled with bat files what for again, launching one of them does nothing?

You may want to read the build scripts section.

well technically that’s all the process that I’ve already done :wink:
I’m I missing something ?
I think the error is more technical

What are the full last two commands that you run, before hitting the obstacle?

what commands, I used cmake-gui, I disabled
urho_angelscript
urho_ lua
urho_luajit
that’s all, everything seems fine, I run Visual Studio, chnage to release and these errors pops up
cannot open file urho3d.lib
and more errors in linux_adapter.cpp like expected identifier and like

errno_t mbstowcs_s(size_t *,wchar_t (&)[_Size],const char *,size_t) throw()’: function template has already been defined (compiling source file C:\Users\user\Desktop\Urho3D-master\Source\ThirdParty\SLikeNet\Source\src\BitStream.cpp)|SLikeNet|C:\Users\user\Desktop\Urho3D-master\Source\ThirdParty\SLikeNet\Source\include\slikenet\linux_adapter.h

maybe from the lib missing ?

Did you try setting the WIN32 option?

where ? next to debug/release combobox there is only x64 no option for 32 and I don’t think that’s the case

I’m unfamiliar in bat country. Maybe someone else can help you.

I just have to smack my head then :frowning:

Either that, be patient, or install Linux. There’s alternatives.

noway, I’m unfamiliar in linux country

It’s free of bats. :bat:

and full of sh (shit)

bull.sh makes the flowers grow. :sunflower:

I love my bats gives me batman powers(not this time)

1 Like

Do you love them too much to execute them, and digest the outstream?