How to pass build options?

Im trying to build Urho3D on Windows myself using the build script but i dont know how to pass aditional parameters into the build options, i currently have this:

cmake_vs2017.bat build64 -URHO3D_64BIT=1 -URHO3D_LUAJIT=1 -URHO3D_SAFE_LUA=1 -URHO3D_C++11=1 -URHO3D_SSE=1 -URHO3D_D3D11=1 -URHO3D_LIB_TYPE=STATIC  

it works but it doesnt generate a 64bit vs2017 project even though i have -URHO3D_64BIT=1 specified.

You have to prepend -D to the option. -DURHO3D_64BIT=1 etc… See

Thanks for the answer !
but is it normal to have A LOT of Warnings while building because i got about 300 warnings about type conversion and i even got 3 errors but the library still compiled successfully.
some screen:

The compiler warnings are normal, especially when they are from 3rd-party library dependency. Although we could fix the code to get rid of those warnings, we try not to do so because it will make the 3rd-party library upgrade process more difficult than they already are. As for compiler error, there should not be any, but I haven’t tried to build Urho using VS lately. Show us what are those errors.

its something with the Assimp lib

it says that ‘!=’ is not valid for a struct and that ‘!=’ wasnt overloaded for type Assimp::WordIterator
but its like in the algorithm file

We recently just upgraded Assimp to version 4.0.1 form 3.2, and the X3D support is a new addition in version 4.0.0. So, it would appear you have found a bug when building that on VS. The latest Assimp build fine on Linux using GCC with all the options enabled. You can raise this as an issue in our issue tracker or better yet, try to fix it and submit it as a PR.

The Assimp is a dependency for AssetImporter tool only.

apparently there is allready a issue open for that exact problem

its probably going to be fixed in the next release
in the meantime im going to fallback to visual studio 2015

Thanks for the link. I have raised it as a new issue, so other VS users could find it if they hit the same problem.