How to prevent shadows from appearing behind the wall

Hi, here is the problem:

The shadow appears on the floor but also on the wall of the floor beneath. I know that this is a common problem. But is there any solution? Maybe another kind of shadow-rendering? I’m using the default way, as it is used in all the samples.

Greetz,Tom

Shadow-map can only mask out light for what it knows about (what was rendered into it).

Either your walls need to be marked as not to receive shadows or your upper-floors need to be set to also cast shadows so the shadow-map is more complete.

2 Likes

Thx for your advice. Since ceiling and wall are one mesh (atm) I go for setting the wallparts to cast shadows as well. And it works as intended… :+1:

@Sinoid : Hmm,…how exactly would I mark an object as “not to receive shadows”? Would this be done with the shadowmask?