iOS :'Skipped autoload path 'Autoload'-Exception in deployme

I think is deserved dedicated thread .
reading this : urho3d.github.io/documentation/1 … lding.html in the documentation
or this thread : topic1406.html
i didn’t understand what i should do .
i compiled successfully the 23_Water example and tried to deploy it to my device ( iPhone 5 )
but it gave me error :

015-12-26 09:13:11.843 23_Water[1486:864806] Created 1 worker thread
2015-12-26 09:13:11.848 23_Water[1486:864806] Added resource path /private/var/mobile/Containers/Bundle/Application/FB626FAB-96FD-41D1-87AD-504FE05A3423/23_Water.app/Data/
2015-12-26 09:13:11.849 23_Water[1486:864806] Added resource path /private/var/mobile/Containers/Bundle/Application/FB626FAB-96FD-41D1-87AD-504FE05A3423/23_Water.app/CoreData/
2015-12-26 09:13:11.850 23_Water[1486:864806] Skipped autoload path 'Autoload' as it does not exist, check the documentation on how to set the 'resource prefix path'

from SDL_uikitopenglview.m
line 96

[context renderbufferStorage:GL_RENDERBUFFER_OES fromDrawable:(CAEAGLLayer*)self.layer];

also all my data files are in the bin directory

is there something that i missed in creating the or deployment the project to device ?

To my understanding, the autoload is a feature not a bug. :wink:
The message you observed should just be a warning log entry instead of an error log entry. In other platform you can see the distinction of the log entry type more clearly. In iOS platform it looks like the log entry type is not displayed. Do you actually have any specific problem with your app despite all this? BTW, we all get this warnings unless we actually have the “autoload” directory created. Perhaps we could silence this warning.

Thanks for the replay , maybe i was misunderstood
but i have exception in deployment see line 96 in the picture
and the log print is the last thing i see , maybe it warning but it the last thing .
so the problem is the exception not the log.

I see. Perhaps then you need to change the subject of this topic. As for your exception, I have no idea what went wrong.

Did some successfully deployed to iOS real device , it seams that there is always problems with iOS device deployment . no matter what version .
Thanks

There is a bug in iOS 8.2 on your iPhone. See: github.com/BradLarson/GPUImage/issues/2022.