Mac retina window

i want the banner of the mac apps to be in the native resolution
but the examples seem to have this odd down scale
have tried engineParameters_[EP_HIGH_DPI] = true; but not getting any different results
Untitled-1

got the same problem with popup errors (comparing with cmake popup)

Are you using latest master branch or release 1.6?

The first issue might be due to a missing property key/value in the macOS bundle info plist file to use the high DPI mode. The second issue is a common pitfall for new user. Read the docs (use the keyword to search) as suggested by the error message.

In the Application::Setup or in the application parameters starting file:

engineParameters_[“HighDPI”] = true;
engineParameters_[“WindowWidth”]=HSIZE;
engineParameters_[“WindowHeight”]=VSIZE;

HSIZExVSIZE = your mac high dpi chosen res, eg 2048x1280

Using 1.6 stable, on Os X 10.12.6

Also setting engineParameters_[“VSync”] = true and engineParameters_[“FullScreen”] = true can help…

ok that was it. why is that missing in the plist by default? as far as i can see every modern mac last few years are retina these days

Because the core devs (well, except Lasse recently) do not have Mac with Retina display yet, so we could not tell the difference it makes on our monitor :slight_smile:. You are welcome to make a PR to fix it. Actually the existing template was shamelessly taken from CMake quite some time ago and have not received any update. I am aware that the newer version of CMake has updated the plist file and sooner or later plan to make the sync again.

so i looked at it but im using the mac app bundling and it still gives that error wen running with xcode, but its fine wen just opening the app the documentation did not say how to solve this
wich is going to make it hard to debug

how do i make it ignore this resource path since it should use the bundled Data/CoreData

update:
never mind figured it out
had to add this -pp /to/Data&CoreData/folder
in Product -> Sheme -> Edit Sheme… -> Run -> Arguments

Yes, that is one of the way. You may want to switch the doc version to the same version of Urho3D library you are using.