NullPtr UI Cursor Bug 1.7.1

In 1.7.1 when implementing a raycasting feature I ran into a bug where the cursur of the UI subsystem was a nullptr.

2 Likes

Hey codexhound, welcome to the community! :boom:

Be aware there are two kinds of cursors in Urho - the system cursor, and custom UI cursor - if you did not create a custom UI cursor, then none exists, and that would very likely explain the null exception.
Generally, I recommend using a custom cursor, if for no other reason, than this: not all platforms have a native cursor.

Thanks, this is my new favorite engine. Was looking for a broadly programmatic and lightweight one and finally found it. I highly dislike the UI based ones like unity. I’ll keep that in mind about the cursor but I’m still not sure whether this a bug or a feature???!

3 Likes

It’s a feature - there is support for “native cursors” but I don’t recommend that pathway. Use a virtual cursor, and it works on all platforms. I can provide more information on request. Don’t want to poison your thread!

  • Yeah its my favourite engine lately as well. It’s pretty solid, and it’s free, like free beer, free.