Post Processing Order


#1

I’ve read on the forums that the AutoExposure, and bloom need to be in a certain order for the results to be render correctly. Is this correct? I get a little color washing if anyone has seen my post under the projects thread. It’s not bad, but look a little off to me.

	graphics->SetSRGB(true);
	renderer->SetHDRRendering(true);

	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/AutoExposure.xml"));
	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/BloomHDR.xml"));
	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/Tonemap.xml"));
	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/FXAA2.xml"));

	effectRenderPath->SetEnabled("BloomHDR", true);
	effectRenderPath->SetEnabled("FXAA2", true);
	effectRenderPath->SetShaderParameter("BloomHDRMix", Vector2(exposure, 2.0f));

#2

So no one knows if AutoExposure should come before or after BloomHDR?


#3

No, everyone’s hung over from new year’s eve.

Also, happy new year! :confetti_ball: :slightly_smiling_face:


#4

LOL, I figured that was it. :stuck_out_tongue:

I tried searching the docs, and the forums, but did not find anything.


#5

Some questions on HDR and sRGB


#6

Thanks. I did not find this on my initial search.

	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/FXAA2.xml"));
	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/AutoExposure.xml"));
	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/BloomHDR.xml"));
	effectRenderPath->Append(cache->GetResource<XMLFile>("PostProcess/Tonemap.xml"));

This is how I have it now.