Segment fault (generated core)

Hello comunity !!
So im on Arch Linux and i have compiled Urho3D from github, i didnt liked the fact that in Eclipse the imports headers etc show like missing, even though it compiles correctly. I got the idea of installing Urho3D from Arch package repos, and that in fact corrected the missing imports and headers but now when i compile succesfuly a new project and i run the Linux exe, the game window closes and theres a message in terminal Segment fault (‘core’ generated) (Hope this is the right translation from Spanish :smile:) Thank you in advance !

1 Like

It is called “core dump”. It is hard to say why it crashed without knowing what exactly have you changed. When you break the engine, you keep the pieces as well. :grin:

2 Likes

Sorry @weitjong i dont know how i fixed it, i was drawing a lot of things, maybe that was the reason, the Arch packages seem to work ok in case anybody here uses it, they work ok. I have also rebuild the project from scratch so its difficult to say what was the reason. Thank you again