[SOLVED] Model not rendering correctly

Hey guys

I created this model in blender:

It has a diffuse map and a normal map:

I imported it into Urho3D’s editor, created a new material “Hound.xml” and used the technique “DiffNormal” from the CoreData folder. There are two things I noticed.

  1. The preview in the material editor is showing the correct result, but the model remains very dark. What am I doing wrong?
  2. The teeth, tongue, and eyes are white. They are submeshes, but all submeshes are UV-mapped to the same single image. Why is the body rendering with textures but the other submeshes not?

Check “Material list” in the export settings. Currently your material slots are empty.

Enable “Tangent” in exporter

Generating tangents solved my first issue, thanks! Now I just need to figure out why the teeth and tongue are still white. Any ideas?

[quote=“TheComet”]Generating tangents solved my first issue, thanks! Now I just need to figure out why the teeth and tongue are still white. Any ideas?

enable “material text list” in exporter

I’m exporting as .dae from blender and using AssetImporter to convert to .mdl, so that option isn’t available as far as I can see.

just use blender exporter github.com/reattiva/Urho3D-Blender

I never got that to work. I have it installed and enabled as an AddOn (also clicked save user settings):

But it doesn’t show up as an option:

placement for this plugin

Cool, thanks for the help guys!