[SOLVED]RenderTarget not working

Hello guys, i’m here again, i need to get render Target but is not working, i’m follow the sample but not working,i’m Using Directx11

Hello,

Could you give a little more information or code, or what part of what sample you refer to?

As I understand render targets, you can define them in code, or a RenderPath XML - for example github.com/urho3d/Urho3D/blob/m … /Bloom.xml
More on
RenderPaths urho3d.github.io/documentation/ … paths.html
Rendering urho3d.github.io/documentation/ … ering.html

Here is my code

Texture2D* tex =new Texture(context_);
tex->SetSize(500,500,Graphics::GetRGBFormat(),TEXTURE_RENDERTARGET);
RenderSurface* surf = tex->GetRenderSurface();
surf->SetViewport(0,_viewport);

Is any more information written to the log file*?

  • by default on MS Windows, something like %APPDATA%\urho3d\logs*.log (\Users\user\AppData\Roaming\logs*.log)

I solved, but the bug is ocur
I’m changed the RenderSurface to update always
Its working fine,but i m show the Texture in Sprite, Sprite is render Texture normal but the viewport is not rendered, the viewport is rendered Black
Sorry again for my english

Maybe a problem in defining the new Viewport?
github.com/urho3d/Urho3D/blob/m … e.cpp#L194