[SOLVED] Texture quality settings

hey,
i have a problem with the Texture quality settings … if i edit the settings the background image changes(zooms in or tiled) … dont know why ? is it a bug or did i do something wrong?

the background is is created with :

       // Create Background sprite and add to the UI layout
	Texture2D* logoTexture = cache->GetResource<Texture2D>("Textures/Background/1_7.png");
	UI* ui = GetSubsystem<UI>();
	backgroundSprite_ = ui->GetRoot()->CreateChild<Sprite>();

	// Set Background sprite texture
	backgroundSprite_->SetTexture(logoTexture);

UI textures will not react kindly to texture quality settings (mip skipping), as the UI elements define absolute pixel rects which causes the tiling. However, the engine cannot automatically know which textures are used for UI. Put the following parameter XML file alongside your UI image file with just the file extension replaced (for example Textures/Background/1_7.xml), similarly like there exists one for the default UI textures such as Textures/UI.png.

<texture>
    <mipmap enable="false" />
    <quality low="0" />
</texture>

The ‘quality low=“0”’ line tells the engine to never reduce quality.

1 Like

hey,

thx i will do that ^^