[SOLVED] Un-androiding build

How does one remove android from their build configuration?

Thanks,
Chris

Hey Chris,

I’m not sure about this but I think you could tweak the CMakeCache.txt where:

//Setup build for Android platform
ANDROID:BOOL=OFF

or you can run CMake GUI and point to the source and build directory so it reads your recent configuration. File -> Reload Cache then edit.

Here’s my setup when I point and reload my cache

I figured it out. There is no option to turn it off. The cmake_gcc script detects an ENV var ANDROID_NDK. If you have the var you get an android build. I commented out the lines in the cmake_gcc.

EDIT:
Nevermind I havn’t gotten it figured out yet. Android keeps forcing itself on in the LUAJIT buildvm build.

The LuaJIT build mechanism will always attempt to build the Lua VM natively for all the requested cross-compiling targets. The “request” file is generated by our CMake build script when you configure a project with LuaJIT enabled for a non-native platform like Android. Try remove the “buildvm-android-arch.txt” from the PROJECT_ROOT_DIR/Bin directory. That’s the request file name, if I remember it correctly. Then reconfigure your native project by calling cmake_gcc.sh again.

Removing the Bin/buildvm-android-arch.txt file fixed it!

Thanks everyone for your time.