WARNING: .blend import/export may result wrong normals

AssImp .blend import and Urho3D-Blender export may result wrong normals.

A workaround is to export to .dae/.fbx and then import it with AssetImporter.

Direct .blend import/export, wrong normals:

Workaround, correct normals:

I tested it with this viewer: assimp.org/main_viewer.html
…to make sure it’s a problem with Assimp and not something Urho3D does, and it still happens.
I opened an issue for Assimp:
github.com/assimp/assimp/issues/816

Not sure if Urho3D-Blender uses Assimp, if not it also has this bug.

Are you using the auto-smooth option? If so, then in that case blender is using a new feature called split normals.

Try the branch in this issue: github.com/reattiva/Urho3D-Blender/issues/45

Maybe assimp and blender importer used differenet methods of triangulation. Try manually triangulation of model before baking of normal map

Also check “tagent” flag in exporter

[quote=“hd_”]Are you using the auto-smooth option? If so, then in that case blender is using a new feature called split normals.

Try the branch in this issue: github.com/reattiva/Urho3D-Blender/issues/45[/quote]

I have Auto Smooth enabled and disabling it results the same error, so it should be the case.
I’ll try the Urho3D-Blender branch.

1vanK - These aren’t the problems.

EDIT:
split normals branch solved it.