Why something looks okay in preview but not in the scene?

Hello,

I’m trying to sort something out. Maybe someone can explain why something looks okay in the preview box but in the actual scene the specularity is wrong? The UV map was done correctly etc.

I can’t match the light to show the texture in the editor. I’ve been playing around with the code the last hour trying to figure out whats wrong. I can’t. Everything seems to be set right right.

imgur.com/a/mbFZp

[code]

<?xml version="1.0"?> [/code]

Vivienne

I think I got some better results. I am just not sure how to element the line area near the wall tops. There is a external light source outside the hanger/room with light source cast shadow, wall set to cast shadows, but somehow it’s still being calculated meaning the light source. Creating the top line on the walls.

I suppose that you got falling shadow from roof to walls.
I guessing because you room composed with separated models try to join it into one solid model and place global light in room not outside.

Actually for indoor scenes like room or angars you better build level in blender or other 3d editor and bake lighmap.
see dima’s example: youtube.com/watch?v=qAl2m483RF0
then place in it local light in room if needed or better use something like faked lights

[quote=“codingmonkey”]I suppose that you got falling shadow from roof to walls.
I guessing because you room composed with separated models try to join it into one solid model and place global light in room not outside.

Actually for indoor scenes like room or angars you better build level in blender or other 3d editor and bake lighmap.
see dima’s example: youtube.com/watch?v=qAl2m483RF0
then place in it local light in room if needed or better use something like faked lights[/quote]

Hmmm. I would love to do the latter but considering the rooms will be completely customizable including light sources. I might have to layout out the room then combine the messhes.